Performance Report WorkstepActivity

Ansicht von 3 Beiträgen - 1 bis 3 (von insgesamt 3)
  • Autor
    Beiträge
  • #2357
    Anonym

    Seit einiger Zeit beschweren sich die Kollegen, daß der Report WorkstepActivity.jrxml extrem langsam läuft: 14 Sekunden bis zum fertigen PDF. Vermutlich ist das seit dem Umstieg auf Version 3.0.19 (Produktiv-) bzw. 3.0.20 (Testsystem) aufgetreten – leider wurde das nicht sofort gemeldet. Der gleiche Report läuft auf dem Openz-Demosystem wesentlich schneller.
    Ich denke nicht, daß unser Server zu lahm ist, alles andere läuft fix und ‘eigentlich’ ist der Report bzw. der SQL darin ja nicht so kompliziert. Da gibt’s ganz andere Herausforderungen die gut laufen. 😛
    Catalina.out und der Postgres-Log wirft keine Fehlermeldung, ein Postgres-Prozess zeigt mit ‘top’ auf einem Kern 100% an – alles andere ist eher unterbschäftigt. Reindizierung und Bereinigen der DB brachte nix. RAM und Swap haben noch ausreichend Reserve.
    Woran kann es liegen?
    Auffällig ist, daß keine ‘.jasper’-Dateien des Reprts (der Sub-Report natürlich auch nicht) erzeugt wird bzw. ist. Kann das der Grund sein? Oder kann es an den Berechtigungen des Dir’s ‘…/smartui/printing/’ liegen? Die stehen zur Zeit auf ‘root:root’ mit ‘drwxr-xr-x’.
    Die Startparamter für Tomcat finde ich gerade nicht…

    PS: Ach ja, es handelt sich um ein etwas älteres qcow2 (update bzw. -grade vor etwa einem Jahr), die Postgres-Version ist 9.1.16 und Java 1.7.0_79

    #2517
    Anonym

    Super! Ich weiß nicht genau was Ihr gemacht habt, aber der Report läuft nun fast zu schnell: 🙂 Wer so schnell Arbeitet verechnet sich bestimmt! 😀

    Vielen Dank, das macht das Arbeiten mit der Arbeitsvorbereitung deutlich effektiver.

    ***Gelöst***

    #2518
    Anonym

    Problem gelöst.

Ansicht von 3 Beiträgen - 1 bis 3 (von insgesamt 3)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.
Scroll to Top