PDF Druck bleibt leer (weiß)

Ansicht von 12 Beiträgen - 1 bis 12 (von insgesamt 12)
  • Autor
    Beiträge
  • #2507
    FlorianFlorian
    Teilnehmer

    Hallo, zu Testzwecken sind wir aktuell dabei eine openZ Installation durchzuführen. Das vorige Thema #1302 hat uns schon weitergebracht und wir konnten somit die Fehlermeldung “Report processing failed – Unable to process report selection” lösen. Wenn wir nun aber, wie in der Installationsanleitung beschrieben, den Rechnungstestdruck durchführen, wird nur ein leeres PDF erstellt. An was könnte dies liegen?

    #2509
    Thomas TiedtkeThomas Tiedtke
    Verwalter

    Hallo Dosemetrics.

    Beim Druck können verschiedene Templates (Vorlagen) gewählt werden, die im Druck-Popup ausgewählt werden können. Vorausgesetzt das Dokument ist Aktiv.
    Ist das Dokument noch im Status Entwurf kann ein Template nicht ausgewählt werden und es wird das Standard Template genommen, bzw, wenn kein Standard gesetzt ein zufälliges Template.

    Den Standard stellt man hier ein:
    Einstellungen || System-Stammdaten || Dokument-Typ || Belegarten
    auswählen Dokument: Invoice (AR)
    wechseln in den Unterreiter: Report Vorlagen
    Dort das Feld Standard bearbeiten.
    In Version 3.5.0 sollte die Datei OpenZ Standardreport.jrxml als Standard gesetzt werden.
    In den Versionen davor die Datei Rpt_Standard.jrxml.

    #2511
    FlorianFlorian
    Teilnehmer

    Hallo Thomas,

    vielen Dank für die schnelle Reaktion!

    Den Belegstatus der Testrechnung hatten wir auf “aktiv” gesetzt. Die Templates können wir in dem Druck-Popup auswählen.

    Unter Belegarten waren beide Dateien (OpenZ Standardreport.jrxml und Rpt_Standard.jrxml) auf Standard gesetzt. Dies haben wir geändert. Jetzt ist nur noch “OpenZ Standardreport.jrxml” Standard. (Wir nutzen OpenZ 3.5.0)

    Das PDF bleibt weiterhin leer.

    #2512
    Thomas TiedtkeThomas Tiedtke
    Verwalter

    Dann bitte zu Kontrollzwecken einmal im Druck-Popup aktiv die Vorlage Rpt_Standard.jrxml auswählen und drucken.
    Was passiert?

    #2513
    FlorianFlorian
    Teilnehmer

    OpenZ Standardreport.jrxml -> Standard entfernt
    Rpt_Standard.jrxml -> Standard gesetzt

    Das führt bei dem Testrechnungsdruck zu der Meldung “Report processing failed – Unable to process report selection”

    #2514
    Thomas TiedtkeThomas Tiedtke
    Verwalter

    jetzt hast du gleich den ganzen Standard verändert, das hatte ich gar nicht gewollt, sollte aber aufs gleiche herauskommen.
    Im Druckpopup kann man nämlich einfach die Vorlage auswählen welche verwendet werden soll 😉
    Ich hätte zB darauf getippt das warum auch immer der Paymenschedule report gedruckt wird, der funktioniert nämlich nur für Zahlpläne und bringt keine Positionsinformationen.

    Aber wenn auch der alte Standardreport hier einen Fehler produziert, dann ist da was anderes Faul.
    Da muss einer der Entwickler was zu sagen, ich selbst bin da eher der Anwendungsexperte.

    #2515
    FlorianFlorian
    Teilnehmer

    OK, danke schon mal. Warten wir auf die Reaktion eines Entwicklers.

    #2522
    Thomas TiedtkeThomas Tiedtke
    Verwalter

    Manchmal ist der Teufel ein Eichhörnchen und hat irgendwo eine kleine Nuss versteckt …

    Nach langem Suchen habe wir nun noch etwas ganz profanes herausgefunden.
    Es ist aufgefallen, dass es notwendig ist, ein Logo für Dokumente entweder in der Druckkonfiguration zu hinterlegen oder aber direkt unter dem Punkt [i]Einstellungen || Mandanten || Mandant || Mandant >> Mandant Info
    [/i]
    Ist kein Bild hinterlegt funktioniert der Ausdruck in der Version 3.5.00.011 leider nicht.
    In keinem unserer Test- und Kundensystemen ist das der Fall und tauchte daher nicht bei uns auf.
    In den folgenden Versionen korrigieren wir das…

    #2523
    FlorianFlorian
    Teilnehmer

    Besten Dank für diese Info. Wir haben uns unabhängig davon entschlossen auf das System zu setzten und dieses auf neuer Hardware aufzusetzen. Dafür werden wir die Einrichtung nochmals durchführen und diesen Hinweis beachten. Wir würden in diesem Jahr gerne mit der Community Version einen Testbetrieb fahren und zum kommenden Jahr live gehen. Ist es im kommenden Jahr dann möglich, problemlos auf die Enterprise Version zu wechseln?

    #2524
    Thomas TiedtkeThomas Tiedtke
    Verwalter

    [quote=”Dosimetrics” post=1331]…. Ist es im kommenden Jahr dann möglich, problemlos auf die Enterprise Version zu wechseln?[/quote]

    Offtopic: Upgrates von Community zu OpenZ Enterprise oder OpenZ CloudService sind immer möglich.

    #2525
    FlorianFlorian
    Teilnehmer

    Problem gelöst.

    #2526
    Thomas TiedtkeThomas Tiedtke
    Verwalter

    [quote=”thomas” post=1330]Manchmal ist der Teufel ein Eichhörnchen und hat irgendwo eine kleine Nuss versteckt …

    Nach langem Suchen habe wir nun noch etwas ganz profanes herausgefunden.
    Es ist aufgefallen, dass es notwendig ist, ein Logo für Dokumente entweder in der Druckkonfiguration zu hinterlegen oder aber direkt unter dem Punkt [i]Einstellungen || Mandanten || Mandant || Mandant >> Mandant Info
    [/i]
    Ist kein Bild hinterlegt funktioniert der Ausdruck in der Version 3.5.00.011 leider nicht.
    In keinem unserer Test- und Kundensystemen ist das der Fall und tauchte daher nicht bei uns auf.
    In den folgenden Versionen korrigieren wir das…[/quote]

    Hier noch eine Ergänzung:
    Es reicht, wenn im Pfad “Einstellungen || Unternehmen || Organisation || Organisation” ein Logo hinterlegt ist.
    Wenn nur im Pfad “Einstellungen || Mandanten || Mandant || Mandant >> Mandant Info” im Feld “Standard Firmen Logo für Dokumente” ein Logo hinterlegt ist, funktionierte der Druck noch nicht.

Ansicht von 12 Beiträgen - 1 bis 12 (von insgesamt 12)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.
Scroll to Top