Fehler beim Drucken von Aufträgen

Ansicht von 8 Beiträgen - 1 bis 8 (von insgesamt 8)
  • Autor
    Beiträge
  • #1594
    Anonym

    Hallo,
    wir haben folgendes Problem, sobald wir einen Bestellauftrag drucken wollen, bekommen wir folgende Fehlermeldung:

    Report processing failed
    Unable to process report selection

    Im Tomcat log wird folgendes angezeigt:

    Caused by: org.postgresql.util.PSQLException: FEHLER: Spalte zspr.footerbank existiert nicht

    Wir benutzen die fertige VMDK der Version 2.6.86 von OpenZ.
    Gibt es eine Möglichkeit dieses Problem irgendwie zu lösen?

    #1595
    Anonym

    Hallo pt_it,

    herzlich willkommen erst einmal.
    Haben Sie diesen Beitrag gelesen? http://openz.de/index.php/component/discussions/2/263-export-von-tabellenansichten-fehler-in-vms-mit-der-version-86.html?Itemid=
    Wenn ja, können Sie mir sagen welchen Report Sie dort benutzen?

    Beste Grüße
    Danny Heuduk

    #1596
    Anonym

    Danke für die schnelle Antwort.
    In meiner VM gibts es kein /home/openz sondern /home/zisoft/openz/, habe zum Testen trotzdem den Ordner erstellt und die Rechte vergeben. Leider ohne Erfolg.
    Habe mal in der Datenbank nachgeschaut, ob diese Spalte footerbank überhaupt existiert, jedoch konnte ich nichts in der kompletten Datenbank finden.
    Komischerweise hat dieses Ausdrucken schon einmal funktioniert.
    Ich weiß jetzt nicht genau welcher Report da angestoßen wird, aber hier die Abfolge meines Ablaufes:
    Bestellwesen || Transaktionen || Bestellung (Einkauf) || Aufträge -> einen auswählen und drucken.

    #1597
    Anonym

    Vielen Dank für die Infos.

    die Spalte ist mir auch unbekannt.
    Können Sie mir evtl einen größeren Teil des Tomcat Logs senden? (catalina.out / openz.log)

    ich nehme an Sie verwenden den Rpt_Standard.jrxml. Hier in OpenZ nachzuvollziehen Einstellungen || System-Stammdaten || Dokument-Typ || Belegarten –> Order (PO)

    Haben Sie auch alle nötigen Infos unter der Organisation (die Sie zum Ausdrucken nutzen möchten angelegt?

    Einstellungen || Unternehmen || Organisation || Organisation >>
    Hier müssen Datensätze für die Printconfig etc existieren.

    Lässt sich der Bestellauftrag aktivieren?

    Vielleicht gibt das einen Hinweis.

    Beste Grüße
    Danny Heuduk

    #1598
    Anonym

    Hier gibt es mal einen großen Auszug des Tomcat logs:
    http://pastebin.com/LjAccXKi

    Genau es wird der Report Rpt_Standard.jrxml genutzt.

    Die Bankverbindung und Co sind im Footer 1-5 bei den Einstellungen für Ausrucke hinterlegt.

    Der Bestellauftrag ist bereits aktiviert.

    #1599
    Anonym

    Hallo,

    schon in der ersten Zeile des Logs ist der Fehler.

    Es wird ein anderer Report benutzt RptC_OrderPO, der versucht auch die footerbank Spalte zu nutzen, die es aber nicht mehr gibt. Der benutzte Report ist also falsch.

    Deaktivieren Sie diesen Datensatz aus dem Dokumententyp: Purchase Order Report template.

    Beste Grüße
    Danny Heuduk

    #1601
    Anonym

    Vielen lieben Dank!!!
    Hat funktioniert, komischerweise hat niemand was an den Standard Reports geändert.
    Aber hauptsache es funktioniert wieder 🙂

    #1602
    Anonym

    Super!

    Das freut mich.

    Beste Grüße
    Danny Heuduk

Ansicht von 8 Beiträgen - 1 bis 8 (von insgesamt 8)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.
Scroll to Top