Build failed beim “Anlegen einer Entwicklungsumg.”

Ansicht von 4 Beiträgen - 1 bis 4 (von insgesamt 4)
  • Autor
    Beiträge
  • #2065
    Anonym

    Hallo,

    Beim Anlegen einer Entwicklungsumgebung ist mir bei Schritt 2 “Kompilieren der SourceCodes” beim Befehl “ant compile.complete” der build fehlgeschlagen. Alle anderen Schritte haben funktioniert. Unter “localhost:8080” erreiche ich den Server, jedoch funktioniert “localhost:8080/openz” nicht. Der ant build log befindet im folgenden Link. Wie geht es weiter?

    http://www.file-upload.net/download-11740629/FehlerOpenZ.zip.html

    #2066
    Thomas TiedtkeThomas Tiedtke
    Verwalter

    Es sieht danach aus, das die Datenbankversion nicht übereinstimmt mit der Version in den Sourcen.

    #2068
    Anonym

    Vielen Dank. Es lag daran, dass der Datenbankimport nicht vor den “ant” Befehlen geschah. Alles builds sind nun erfolgreich.

    Jetzt bin ich soweit, dass bei Eingabe von “localhost:8080” im Firefox die Tomcatseite erscheint und, dass bei der Eingabe von “localhost:8080/openz” der Explorer autmatisch auf “http://localhost:8080/openz/security/Menu.html” weiterleitet. Es erscheint dann aber ein Statusmeldung mit der Nachicht “The requested resource is not available.”. Auch wenn ich direkt auf die Log-in Seite “http://localhost:8080/openz/security/Login_FS.html” möchte, erscheint die selbe Fehlermeldung. Wie komme ich weiter?

    Im Anhang ist der Eclipse Server Report.

    #2071
    OpenZ -GOpenZ-G
    Verwalter

    Hallo Herr Oemer,
    es sieht danach aus, dass das Deployment der erzeugten Klassen in Tomcat bei Ihnen nicht erfolgt ist (class not found).
    Haben Sie ant build.deploy ausgeführt?
    Ist der tomcat richtig eingerichtet?
    Wir können hier im Forum natürlich nicht in die Details Ihrer lokalen Entwicklungsumgebung und Installation hineinschauen und die Zusammenhänge, die dort auf dem speziellen System wirken, erörtern.
    Das Forum ist mehr für die Klärung allgemeingültiger Fragen gedacht.
    Ihre Entwicklungsumgebung sollten Sie entsprechend der Anleitung eingerichtet haben.
    Beste Grüße

Ansicht von 4 Beiträgen - 1 bis 4 (von insgesamt 4)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.
Scroll to Top